Last 5 comments
84 years ago
Rafael:  Thank you very much, I was having a huge headache to solve the very same problem!
91 years ago
Ray:  Having the same problem. Very frustrating. Luckily, for some reason my released version worked on the iPad itself, but now I can't get it to run in the simulator. Getting no such table, which I'm guessing is an initialization error. Will continue to investigate.
91 years ago
Jeremy:  FYI, I've just tried it with the SQLite 3.7.0 preview and the same problem occurs.
Also, I'm not using any extra third-party libraries with my SQLite, so the problem isn't your Unicode extension.
91 years ago
Jeremy:  I'm having the same problem with compiling SQLite against iOS 4 for the iPad simulator, but in my case it works fine running on an actual iPad (also works in the iPhone simulator and on an iPod Touch).
Same problem with 3.6.23.1, 3.6.23, and at least back to 3.6.21. Compiling against iOS 3.2 makes it work, though that's not really an option for iPhone (as opposed to iPad) apps.
I have no idea what to do about it or how big a problem it really is...
91 years ago
Pascal:  The problem seems to have deep roots, however there is a solution, see the updated post. :)
The archive
March 2011  (1)
July 2010  (1)
July 2009  (1)
March 2009  (1)
July 2008  (3)
June 2008  (1)
May 2008  (3)
March 2008  (1)
July 2007  (1)
June 2007  (3)
May 2007  (1)
April 2007  (1)
July 2006  (2)
June 2006  (6)

Disable the dashboardadvisory-daemon

Tuesday, July 4th 2006 - 22:25
So, since 10.4.7, Mac OS X phones home, too. While at the moment, OS X only checks if you run the latest versions of your widgets and no suspicious data is sent, this fact may render some people nervous.
Simple solution: turn the responsible daemon off.
What does phone home is the fetchadvisory-daemon located here:
/System/Library/CoreServices/Dock.app/Contents/Resources/fetchadvisory
And since Apple blessed us with launchd when releasing the Tiger, there is a corresponding plist-file:
/System/Library/LaunchDaemons/com.apple.dashboard.advisory.fetch.plist
This file tells launchd to start this daemon every 28800 seconds, say every 8 hours.
What to do? Simply execute the following command from Terminal: (Thank you Bjarne D Mathiesen for the shortcut)
$ sudo launchctl unload -w \ /System/Library/LaunchDaemons/com.apple.dashboard.advisory.fetch.plist
You need to have Administrator-Privilegies to execute this command!

This will unload the service right at the moment (no reboot necessary) and disable the service temporarily by adding the following to the plist-file:
<key>Disabled</key> <true/>

If you change your mind, use the following to switch it back on (note the slight difference):
$ sudo launchctl load -w \ /System/Library/LaunchDaemons/com.apple.dashboard.advisory.fetch.plist

Note: If you upgraded from 10.3 or earlier to 10.4, then most probably your system wont use launchctl, but old-fashioned init.d instead. See this [macosxhints.com] hint for information.
Bjarne D Mathiesen at 05.07.2006 19:42

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.dashboard.advisory.fetch.plist accomplished the same thing without one having to manually editing the plist file. And no reboot necessary either.
brian walsh at 07.07.2006 20:58

i ran this terminal command, and my mac froze and will not boot back up into the OS. any idea why? and, more importantly, any idea how i can get back to the OS?
Pascal at 08.07.2006 00:35

What did the Terminal say when you entered the command? Where do you get stuck during reboot?
A Mac User at 01.10.2006 21:04

You can also use the Lingon application to turn this off ... which you'll need to do (again!) after installing the 10.4.8 <grrrr> (I now have a Little Snitch rule on all our systems to block this ... even if it is "harmless" today, it's just good security).
uli at 06.03.2007 05:22

for anyone who's not absolutely sure about what he can damage with the terminal: use pref setter [http://www.nightproductions.net/] for acting on a copy of the plist-file (the original file is in use), and replace the original.
Comments are disabled